2016-07-18 130 views
5

È possibile che questi 2 (entrambi sono le versioni più recenti) non sono compatibili? (Nei frammenti: i file locali sono le versioni più recenti, i file recuperati online sono versioni precedenti) C'è qualcosa che posso fare per utilizzare sia localmente?Bootstrap 3.3.6 e JQuery 3.1.0 non compatibili?

Questi frammenti funzionano:

Snippet 1:

<script src="js/jquery-3.1.0.min.js"></script> 
<script src="//netdna.bootstrapcdn.com/bootstrap/3.1.1/js/bootstrap.min.js"></script> 
<link rel="stylesheet" type="text/css" href="css/bootstrap.min.css"> 

Snippet 2:

<script src="https://code.jquery.com/jquery-2.2.3.min.js"></script> 
<script src="js/bootstrap.min.js"></script> 

Questo frammento di codice non funziona:

<script src="js/jquery-3.1.0.min.js"></script> 
<script src="js/bootstrap.min.js"></script> 
<link rel="stylesheet" type="text/css" href="css/bootstrap.min.css"> 

ho provato loro con questo dropdown uomini u:

<nav class="nav navbar-inverse"> 
    <ul class="nav navbar-nav"> 
     <li class="dropdown"> 
      <a href="#" class="dropdown-toggle" data-toggle="dropdown">Info<span class="caret"></span></a> 
      <ul class="dropdown-menu"> 
       <li><a href="html/bussen.html">Bussen</a></li> 
       <li><a href="html/DJs.html">DJ's</a></li> 
      </ul> 
     </li> 
    </ul> 
</nav> 
+0

uso il pacchetto predefinito che viene fornito quando si scarica il bootstrap. – Jai

+0

Possibile duplicato di [modale Bootstrap non visualizzato al caricamento della pagina] (http://stackoverflow.com/questions/34586047/bootstrap-modal-not-show-on-page-load) – vanburen

risposta

-3

Poiché jQuery 3.0 è ancora in alpha test, quindi ha bisogno di tempo compatibile con Bootstrap 3. Y

+1

La versione 3 non è più in alpha .. In effetti 3.1 è stato rilasciato di recente https://blog.jquery.com/2016/07/07/jquery-3-1-0-released-no-more-silent-errors/ – jakob

3

Bootstrap 3 non è compatibile con jQuery 3.0 e sopra al momento. Quindi l'ultima versione di jQuery che può essere utilizzata con Bootstrap 3 è 2.2.4.

Anche se, some ha segnalato che funziona con jQuery Migrate.

È possibile controllare this discussion per ulteriori informazioni.

Aggiornamento

Come MD Ashik ha riferito, le versioni più recenti Bootstrap funzionano bene con jQuery 3+

7

Right Now Bootstrap 3.3.7 vengono aggiornati e jquery jquery-3.1.1 sono ben lavorando per me. non mostrare un singolo errore nella mia console o da nessuna parte. Quindi penso che tu possa usare l'aggiornamento bootstrap.

bootstrap dicono JQuery impostata alla versione 1.9.0 o successiva ..... Link

Bootstrap 3.3.7 supporto 3+ jQuery

ottenere maggiori informazioni in Github Problema Link