Questa è una domanda di convenzione di denominazione di base, ma non ho trovato da nessuna parte che trattasse in modo specifico.Convenzione di denominazione per il metodo di servizio
Ho una classe chiamata Foo e una classe chiamata Bar.
Ho un metodo in un servizio per recuperare tutte le barre per un Foo. Dovrei chiamarla:
GetFooBars(int fooId)
o
GetBarsForFoo(int fooId)
ad espandersi, si potrebbe avere Sbarre per altre classi, per esempio
GetMooBars(int mooId)
o
GetBarsForMoo(int mooId)
Grazie, mi piace che hai specificato "... FooId". Il mio unico avvertimento è che quando vedo "By", piuttosto che "For", mi viene da pensare che sto ricevendo molte (tutte?) Barre che sono state scomposte o ordinate da FooId (o MooId). In alternativa, quando vedo "Per", mi viene da pensare che sto ottenendo un sottoinsieme di tutte le barre solo per un particolare FooId (o MooId). –
Quando vedo un nome come "GetBarsByFooId", mi viene da pensare "filtro per" o "ricerca per". Non avevo mai pensato che potesse significare "raggruppa per" o "ordina per". Ma sono solo io ... Immagino che il fatto che tu stia passando 'fooId' come parametro dovrebbe chiarire l'intento. –